summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2004-01-17 20:58:20 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2004-01-17 20:58:20 +0000
commitac8d82e48844157003809760338f8461a10e9649 (patch)
tree77e9e310e5aa185ca477abe7433091bad8c1e2dd /app-emacs/ilisp-cvs
parentremove ltsp mask, it's released now (diff)
downloadgentoo-2-ac8d82e48844157003809760338f8461a10e9649.tar.gz
gentoo-2-ac8d82e48844157003809760338f8461a10e9649.tar.bz2
gentoo-2-ac8d82e48844157003809760338f8461a10e9649.zip
*** empty log message ***
Diffstat (limited to 'app-emacs/ilisp-cvs')
-rw-r--r--app-emacs/ilisp-cvs/ChangeLog11
-rw-r--r--app-emacs/ilisp-cvs/Manifest8
-rw-r--r--app-emacs/ilisp-cvs/files/60ilisp-cvs-gentoo.el16
-rw-r--r--app-emacs/ilisp-cvs/files/digest-ilisp-cvs-5.12.00
-rw-r--r--app-emacs/ilisp-cvs/files/ilisp-keybindings.el0
-rw-r--r--app-emacs/ilisp-cvs/files/ilisp.asd64
-rw-r--r--app-emacs/ilisp-cvs/files/ilisp.el127
-rw-r--r--app-emacs/ilisp-cvs/ilisp-cvs-5.12.0.ebuild79
-rw-r--r--app-emacs/ilisp-cvs/metadata.xml5
9 files changed, 310 insertions, 0 deletions
diff --git a/app-emacs/ilisp-cvs/ChangeLog b/app-emacs/ilisp-cvs/ChangeLog
new file mode 100644
index 000000000000..ad758766f211
--- /dev/null
+++ b/app-emacs/ilisp-cvs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/ilisp-cvs
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ilisp-cvs/ChangeLog,v 1.1 2004/01/17 20:58:19 mkennedy Exp $
+
+*ilisp-cvs-5.12.0 (07 Jan 2004)
+
+ 07 Jan 2004; <mkennedy@gentoo.org> ilisp-cvs-5.12.0.ebuild, metadata.xml,
+ files/60ilisp-cvs-gentoo.el, files/ilisp-keybindings.el, files/ilisp.asd,
+ files/ilisp.el:
+ Initial import. Ebuild contributed by Matthew Kennedy <mkennedy@gentoo.org>
+
diff --git a/app-emacs/ilisp-cvs/Manifest b/app-emacs/ilisp-cvs/Manifest
new file mode 100644
index 000000000000..b2a46227e74d
--- /dev/null
+++ b/app-emacs/ilisp-cvs/Manifest
@@ -0,0 +1,8 @@
+MD5 a122a56030c1034db9e2d7c21b69a3f0 ChangeLog 411
+MD5 7233f261b9746493fb5b665257b2c17e ilisp-cvs-5.12.0.ebuild 2030
+MD5 fcd33d07e4ee719b01157946734f4fe8 metadata.xml 158
+MD5 f2bfae986fa9c8c6683fe6a404ea2038 files/ilisp.asd 2231
+MD5 d41d8cd98f00b204e9800998ecf8427e files/ilisp-keybindings.el 0
+MD5 5300f587590e83dcdf1f8473f73b5376 files/ilisp.el 4030
+MD5 533216a6b8981b5014c0718d3289cc59 files/60ilisp-cvs-gentoo.el 503
+MD5 d41d8cd98f00b204e9800998ecf8427e files/digest-ilisp-cvs-5.12.0 0
diff --git a/app-emacs/ilisp-cvs/files/60ilisp-cvs-gentoo.el b/app-emacs/ilisp-cvs/files/60ilisp-cvs-gentoo.el
new file mode 100644
index 000000000000..9756d962abc4
--- /dev/null
+++ b/app-emacs/ilisp-cvs/files/60ilisp-cvs-gentoo.el
@@ -0,0 +1,16 @@
+;; -*-emacs-lisp-*-
+;;
+;; Emacs startup file for the Debian GNU/Linux ilisp package
+;;
+;; Originally contributed by Nils Naumann <naumann@unileoben.ac.at>
+;; Modified by Dirk Eddelbuettel <edd@debian.org>
+;; Adapted for dh-make by Jim Van Zandt <jrv@vanzandt.mv.com>
+
+;; Modified for Gentoo by Matthew Kennedy <mkennedy@gentoo.org>
+
+(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'load-path "@SITELISP@/extra")
+
+(if (file-readable-p "~/.ilisp")
+ (load "~/.ilisp")
+ (load "/etc/ilisp/ilisp.el"))
diff --git a/app-emacs/ilisp-cvs/files/digest-ilisp-cvs-5.12.0 b/app-emacs/ilisp-cvs/files/digest-ilisp-cvs-5.12.0
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emacs/ilisp-cvs/files/digest-ilisp-cvs-5.12.0
diff --git a/app-emacs/ilisp-cvs/files/ilisp-keybindings.el b/app-emacs/ilisp-cvs/files/ilisp-keybindings.el
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/app-emacs/ilisp-cvs/files/ilisp-keybindings.el
diff --git a/app-emacs/ilisp-cvs/files/ilisp.asd b/app-emacs/ilisp-cvs/files/ilisp.asd
new file mode 100644
index 000000000000..376463b47595
--- /dev/null
+++ b/app-emacs/ilisp-cvs/files/ilisp.asd
@@ -0,0 +1,64 @@
+;;;; -*- Mode: Lisp; Syntax: ANSI-Common-Lisp; Base: 10 -*-
+;;;; *************************************************************************
+;;;; FILE IDENTIFICATION
+;;;;
+;;;; Name: ilisp.asd
+;;;; Purpose: ASDF system definition file for ilisp package
+;;;; Programmer: Kevin M. Rosenberg
+;;;; Date Started: March 2003
+;;;;
+;;;; $Id: ilisp.asd,v 1.1 2004/01/17 20:58:20 mkennedy Exp $
+;;;;
+;;;; UFFI users are granted the rights to distribute and use this software
+;;;; as governed by the terms of the ILISP license.
+;;;; *************************************************************************
+
+(defpackage #:ilisp-system (:use #:cl #:asdf))
+(in-package #:ilisp-system)
+
+(defun symlink-ilisp-fasls ()
+ (let ((fasls-path
+ (merge-pathnames
+ (make-pathname :directory '(:relative "ilisp"))
+ c-l-c::*fasl-root*))
+ (dest-path (make-pathname :directory '(:absolute "usr" "lib" "ilisp"))))
+ (format *trace-output* "~&Symlinking fasls~%")
+ (dolist (fasl (directory
+ (make-pathname :defaults fasls-path
+ :name :wild
+ :type :wild)))
+ (format t "~S~%" fasl)
+ (when (pathname-type fasl) ;; Crude check to avoid matching a directory
+ (let ((symlink (make-pathname
+ :directory (pathname-directory dest-path)
+ :name (pathname-name fasl)
+ :type (pathname-type fasl))))
+ (when (probe-file symlink)
+ (delete-file symlink))
+ (let ((cmd (format nil "ln -sf ~A ~A"
+ (namestring fasl) (namestring symlink))))
+ (run-shell-command cmd))
+ )))))
+
+#+(or allegro clisp lispworks cmu openmcl sbcl)
+(defsystem :ilisp
+ :name "ilisp"
+ :maintainer "Kevin M. Rosenberg <kmr@debian.org>"
+ :licence "ILISP license"
+ :description "System loader for ILISP inferior-mode lisp interface"
+
+ :perform (compile-op :after (op ilisp)
+ (symlink-ilisp-fasls))
+
+ :components
+ ((:file "ilisp-pkg")
+ (:file "cl-ilisp" :depends-on ("ilisp-pkg"))
+ #+allegro (:file "allegro" :depends-on ("cl-ilisp"))
+ #+clisp (:file "cl-chs-init" :depends-on ("cl-ilisp"))
+ #+cmu (:file "cmulisp" :depends-on ("cl-ilisp"))
+ #+lispworks (:file "lispworks" :depends-on ("cl-ilisp"))
+ #+openmcl (:file "openmcl" :depends-on ("cl-ilisp"))
+ #+sbcl (:file "sbcl" :depends-on ("cl-ilisp"))
+ ))
+
+
diff --git a/app-emacs/ilisp-cvs/files/ilisp.el b/app-emacs/ilisp-cvs/files/ilisp.el
new file mode 100644
index 000000000000..2c7526b9606e
--- /dev/null
+++ b/app-emacs/ilisp-cvs/files/ilisp.el
@@ -0,0 +1,127 @@
+;;; -*- Mode: Emacs-Lisp -*-
+;;;
+;;; Copyright (c) 2002 Kevin Rosenberg GNU License
+
+;;; Mofifications for Gentoo, Matthew Kennedy <mkennedy@gentoo.org>
+
+(defvar ilisp-*directory* "/usr/lib/ilisp/")
+
+(require 'completer)
+
+(setq ilisp-*use-fsf-compliant-keybindings* t)
+(when (file-exists-p "/etc/ilisp/ilisp-keybindings.el")
+ (load "/etc/ilisp/ilisp-keybindings.el"))
+(setq ilisp-*use-frame-for-output* nil)
+(setq ilisp-*use-frame-for-arglist-output-p* nil)
+(setq ilisp-motd nil)
+
+(autoload 'run-ilisp "ilisp" "Select a new inferior LISP." t)
+(autoload 'clisp-hs "ilisp" "Inferior CLISP Common LISP." t)
+(autoload 'allegro "ilisp" "Inferior Allegro Common Lisp." t)
+(autoload 'lispworks "ilisp" "Inferior Lispworks Common Lisp." t)
+(autoload 'openmcl "ilisp" "Inferior OpenMCL Common Lisp." t)
+(autoload 'scheme "ilisp" "Inferior generic Scheme." t)
+(autoload 'guile "ilisp" "Inferior Guile Scheme." t)
+
+(defun alisp ()
+ (interactive)
+ (setq allegro-program "/usr/bin/alisp")
+ (allegro))
+(defun alisp8 ()
+ (interactive)
+ (setq allegro-program "/usr/bin/alisp8")
+ (allegro))
+(defun mlisp ()
+ (interactive)
+ (setq allegro-program "/usr/bin/mlisp")
+ (allegro))
+(defun mlisp8 ()
+ (interactive)
+ (setq allegro-program "/usr/bin/mlisp8")
+ (allegro))
+
+;; (defun cmucl-normal ()
+;; "Inferior CMU Common LISP -- normal core."
+;; (interactive)
+;; (setq cmulisp-program "/usr/bin/lisp -core /usr/lib/cmucl/lisp-normal.core")
+;; (cmulisp))
+;; (defun cmucl-small ()
+;; "Inferior CMU Common LISP -- small core."
+;; (interactive)
+;; (setq cmulisp-program "/usr/bin/lisp -core /usr/lib/cmucl/lisp-small.core")
+;; (cmulisp))
+;; (defun cmucl-safe ()
+;; "Inferior CMU Common LISP -- safe core."
+;; (interactive)
+;; (setq cmulisp-program "/usr/bin/lisp -core /usr/lib/cmucl/lisp-safe.core")
+;; (cmulisp))
+
+(defun sbcl-mt ()
+ "SBCL multithreading."
+ (interactive)
+ (setq sbcl-program "/usr/bin/sbcl-mt --noinform")
+ (sbcl))
+
+(autoload 'sbcl "ilisp" "Inferior Steel Bank Common LISP." t)
+(autoload 'cmulisp "ilisp" "Inferior CMU Common LISP." t)
+
+(setq common-lisp-hyperspec-root "/usr/share/doc/hyperspec/")
+(setq cltl2-root-url "file:///usr/share/doc/cltl/")
+
+(setq ilisp-site-hook
+ '(lambda ()
+ ;; delete any keybindings that start with this sequence, such
+ ;; as oo-browser's bindings
+ (global-unset-key [(control c) (control v)])
+
+ (setq clisp-hs-progam "clisp -a -I")
+ (setq allegro-program "/usr/bin/acl")
+ (setq lispworks-program "/usr/bin/lw-console -multiprocessing")
+ (setq openmcl-program "/usr/bin/openmcl")
+ (setq cmulisp-program "/usr/bin/lisp")
+ (setq guile-program "/usr/bin/guile1.4")
+ (setq cmulisp-local-source-directory "/usr/src/cmucl/")
+ ))
+
+(add-hook 'ilisp-mode-hook
+ '(lambda ()))
+
+;; Loading lisp files starts ilisp
+(set-default 'auto-mode-alist
+ (append '(("\\.lisp$" . lisp-mode)
+ ("\\.lsp$" . lisp-mode)
+ ("\\.cl$" . lisp-mode))
+ auto-mode-alist))
+
+(add-hook 'lisp-mode-hook
+ (function (lambda () (require 'ilisp))))
+
+;;; Load hooks
+(add-hook 'scheme-mode-hook
+ (function (lambda () (require 'ilisp))))
+
+(add-hook 'ilisp-load-hook
+ '(lambda ()
+ (when ilisp-*use-fsf-compliant-keybindings*
+ (setq ilisp-*prefix* "\C-c"))
+ (setq lisp-no-popper t)
+
+ ;; Make sure that you don't keep popping up the 'inferior
+ ;; Lisp' buffer window when this is already visible in
+ ;; another frame. Actually this variable has more impact
+ ;; than that. Watch out.
+ ; (setq pop-up-frames t)
+
+ ;;(message "Running ilisp-load-hook")
+ ;; Define LispMachine-like key bindings, too.
+ ; (ilisp-lispm-bindings) Sample initialization hook.
+
+ ;; Set the inferior Lisp directory to the directory of
+ ;; the buffer that spawned it on the first prompt.
+ (add-hook 'ilisp-init-hook
+ '(lambda ()
+ (default-directory-lisp ilisp-last-buffer)))
+
+ ))
+
+
diff --git a/app-emacs/ilisp-cvs/ilisp-cvs-5.12.0.ebuild b/app-emacs/ilisp-cvs/ilisp-cvs-5.12.0.ebuild
new file mode 100644
index 000000000000..931008bbd653
--- /dev/null
+++ b/app-emacs/ilisp-cvs/ilisp-cvs-5.12.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/ilisp-cvs/ilisp-cvs-5.12.0.ebuild,v 1.1 2004/01/17 20:58:19 mkennedy Exp $
+
+ECVS_SERVER="cvs-pserver.sourceforge.net:80/cvsroot/ilisp"
+ECVS_MODULE="ILISP"
+ECVS_USER="anonymous"
+ECVS_CVS_OPTIONS="-dP"
+
+inherit elisp-common cvs
+
+DESCRIPTION="A comprehensive Emacs interface for an inferior Common Lisp, or other Lisp based languages."
+HOMEPAGE="http://sourceforge.net/projects/ilisp/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc"
+
+DEPEND="virtual/emacs
+ dev-lisp/common-lisp-controller
+ doc? ( virtual/tetex sys-apps/texinfo app-text/texi2html )"
+
+
+S=${WORKDIR}/ILISP
+
+CLPACKAGE=ilisp
+
+src_compile() {
+ make EMACS=emacs SHELL=/bin/sh || die
+ cd extra && for i in *.el ; do
+ elisp-comp *.el
+ done
+ use doc && make -C ${S}/docs
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-install ${PN}/extra extra/*.el extra/*.elc
+
+ insinto /etc/ilisp
+ doins ${FILESDIR}/ilisp.el ${FILESDIR}/ilisp-keybindings.el
+
+ insinto /usr/share/common-lisp/source/ilisp
+ doins *.lisp ${FILESDIR}/ilisp.asd
+ dodir /usr/share/common-lisp/systems
+ dosym /usr/share/common-lisp/source/ilisp/ilisp.asd /usr/share/common-lisp/systems/ilisp.asd
+
+ dodir /usr/lib/ilisp
+ for i in ${D}/usr/share/common-lisp/source/ilisp/*.lisp ; do
+ l=`basename $i`
+ dosym /usr/share/common-lisp/source/ilisp/$l /usr/lib/ilisp/$l
+ done
+
+ insinto /usr/share/${PN}
+ doins *.scm
+
+ doinfo docs/*.info*
+ dohtml docs/*.html
+ dodoc docs/*.ps
+
+ elisp-site-file-install ${FILESDIR}/60ilisp-cvs-gentoo.el
+ dodoc ACKNOWLEDGMENTS COPYING GETTING-ILISP HISTORY INSTALLATION README Welcome
+}
+
+pkg_preinst() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ chown -R cl-builder:cl-builder /usr/lib/ilisp
+ /usr/sbin/register-common-lisp-source ${CLPACKAGE}
+ clc-autobuild-library ilisp yes
+}
+
+pkg_postrm() {
+ rm -rf /usr/lib/common-lisp/*/${CLPACKAGE} || true
+ elisp-site-regen
+}
diff --git a/app-emacs/ilisp-cvs/metadata.xml b/app-emacs/ilisp-cvs/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/ilisp-cvs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>