summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-06-06 18:05:22 +0000
committerUlrich Müller <ulm@gentoo.org>2009-06-06 18:05:22 +0000
commitec6256c6df95aaa3f557bc444036a6fe9f65a895 (patch)
treeeb81f1ff4bee1b403800d2e1b87affe37c97979d /app-admin
parentppc stable #272544 (diff)
downloadgentoo-2-ec6256c6df95aaa3f557bc444036a6fe9f65a895.tar.gz
gentoo-2-ec6256c6df95aaa3f557bc444036a6fe9f65a895.tar.bz2
gentoo-2-ec6256c6df95aaa3f557bc444036a6fe9f65a895.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/eselect/ChangeLog9
-rw-r--r--app-admin/eselect/eselect-1.1.1.ebuild73
2 files changed, 81 insertions, 1 deletions
diff --git a/app-admin/eselect/ChangeLog b/app-admin/eselect/ChangeLog
index 4818cfaf8194..5abb5b9839d7 100644
--- a/app-admin/eselect/ChangeLog
+++ b/app-admin/eselect/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/eselect
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/ChangeLog,v 1.102 2009/06/02 22:32:11 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/ChangeLog,v 1.103 2009/06/06 18:05:22 ulm Exp $
+
+*eselect-1.1.1 (06 Jun 2009)
+
+ 06 Jun 2009; Ulrich Mueller <ulm@gentoo.org> +eselect-1.1.1.ebuild:
+ Version bump. Remove paludis USE flag since it doesn't make much sense
+ without the corresponding dependency; use app-admin/eselect-package-manager
+ for selection of a package manager instead.
02 Jun 2009; Ulrich Mueller <ulm@gentoo.org> eselect-1.1.ebuild,
-eselect-1.1_rc2.ebuild, -eselect-1.1_rc3.ebuild:
diff --git a/app-admin/eselect/eselect-1.1.1.ebuild b/app-admin/eselect/eselect-1.1.1.ebuild
new file mode 100644
index 000000000000..e04b2aab2603
--- /dev/null
+++ b/app-admin/eselect/eselect-1.1.1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect/eselect-1.1.1.ebuild,v 1.1 2009/06/06 18:05:22 ulm Exp $
+
+DESCRIPTION="Gentoo's multi-purpose configuration and management tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/eselect/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="doc bash-completion"
+
+RDEPEND="sys-apps/sed
+ || (
+ sys-apps/coreutils
+ sys-freebsd/freebsd-bin
+ app-admin/realpath
+ )"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/docutils )"
+RDEPEND="${RDEPEND}
+ sys-apps/file
+ sys-libs/ncurses"
+
+# Commented out: only few users of eselect will edit its source
+#PDEPEND="emacs? ( app-emacs/gentoo-syntax )
+# vim-syntax? ( app-vim/eselect-syntax )"
+
+src_compile() {
+ econf
+ emake || die "emake failed"
+
+ if use doc ; then
+ make html || die "failed to build html"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO doc/*.txt
+ use doc && dohtml *.html doc/*
+
+ # needed by news-tng module
+ keepdir /var/lib/gentoo/news
+
+ # we don't use bash-completion.eclass since eselect
+ # is listed in RDEPEND.
+ if use bash-completion ; then
+ insinto /usr/share/bash-completion
+ newins misc/${PN}.bashcomp ${PN} || die
+ fi
+}
+
+pkg_postinst() {
+ # fowners in src_install doesn't work for the portage group:
+ # merging changes the group back to root
+ chgrp portage "${ROOT}/var/lib/gentoo/news" \
+ && chmod g+w "${ROOT}/var/lib/gentoo/news"
+
+ if use bash-completion ; then
+ elog "In case you have not yet enabled command-line completion"
+ elog "for eselect, you can run:"
+ elog
+ elog " eselect bashcomp enable eselect"
+ elog
+ elog "to install locally, or"
+ elog
+ elog " eselect bashcomp enable --global eselect"
+ elog
+ elog "to install system-wide."
+ fi
+}