summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-01-25 17:05:36 +0000
committerMike Gilbert <floppym@gentoo.org>2014-01-25 17:05:36 +0000
commit259b10737539385e8ddd9c50a3841445437419f5 (patch)
treeed836ddc13dfcf00cfbebb0d08c2a3c393aaf575 /app-admin/eselect-python
parentVersion bump (diff)
downloadgentoo-2-259b10737539385e8ddd9c50a3841445437419f5.tar.gz
gentoo-2-259b10737539385e8ddd9c50a3841445437419f5.tar.bz2
gentoo-2-259b10737539385e8ddd9c50a3841445437419f5.zip
Version bump. Includes fix for gentoo-prefix.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'app-admin/eselect-python')
-rw-r--r--app-admin/eselect-python/ChangeLog8
-rw-r--r--app-admin/eselect-python/eselect-python-20140125.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/app-admin/eselect-python/ChangeLog b/app-admin/eselect-python/ChangeLog
index 052f6051394c..2e72ea17cbd0 100644
--- a/app-admin/eselect-python/ChangeLog
+++ b/app-admin/eselect-python/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-python
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.83 2014/01/19 15:59:11 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/ChangeLog,v 1.84 2014/01/25 17:05:36 floppym Exp $
+
+*eselect-python-20140125 (25 Jan 2014)
+
+ 25 Jan 2014; Mike Gilbert <floppym@gentoo.org>
+ +eselect-python-20140125.ebuild:
+ Version bump. Includes fix for gentoo-prefix.
19 Jan 2014; Mike Gilbert <floppym@gentoo.org> eselect-python-20140115.ebuild,
eselect-python-99999999.ebuild:
diff --git a/app-admin/eselect-python/eselect-python-20140125.ebuild b/app-admin/eselect-python/eselect-python-20140125.ebuild
new file mode 100644
index 000000000000..cadf07878c95
--- /dev/null
+++ b/app-admin/eselect-python/eselect-python-20140125.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-python/eselect-python-20140125.ebuild,v 1.1 2014/01/25 17:05:36 floppym Exp $
+
+# Keep the EAPI low here because everything else depends on it.
+# We want to make upgrading simpler.
+
+if [[ ${PV} == "99999999" ]] ; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="git://git.overlays.gentoo.org/proj/${PN}.git"
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://dev.gentoo.org/~floppym/dist/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Eselect module for management of multiple Python versions"
+HOMEPAGE="http://www.gentoo.org/proj/en/Python/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-1.2.3"
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git-r3_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${A}
+ fi
+}
+
+src_install() {
+ keepdir /etc/env.d/python
+ emake DESTDIR="${D}" install || die
+}
+
+pkg_postinst() {
+ if has_version 'dev-lang/python'; then
+ eselect python update --if-unset
+ fi
+ if has_version '=dev-lang/python-2*'; then
+ eselect python update --python2 --if-unset
+ fi
+ if has_version '=dev-lang/python-3*'; then
+ eselect python update --python3 --if-unset
+ fi
+}