summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2015-03-22 13:38:38 +0000
committerJohannes Huber <johu@gentoo.org>2015-03-22 13:38:38 +0000
commite944bf1100f56a831eb2d5b48a16d7b7bd05a76d (patch)
tree92f69cc7c08051331e45e5cba062eb14ae461d7f
parentVersion bump, try both udevadm paths (#539844 by Rick Harris), drop old. (diff)
downloadgentoo-2-e944bf1100f56a831eb2d5b48a16d7b7bd05a76d.tar.gz
gentoo-2-e944bf1100f56a831eb2d5b48a16d7b7bd05a76d.tar.bz2
gentoo-2-e944bf1100f56a831eb2d5b48a16d7b7bd05a76d.zip
Fix src_prepare to respect LINGUAS, bug #543086.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
-rw-r--r--sys-auth/polkit-kde-agent/ChangeLog8
-rw-r--r--sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-auth/polkit-kde-agent/ChangeLog b/sys-auth/polkit-kde-agent/ChangeLog
index 906a7c6af75c..7e8dd0cb085a 100644
--- a/sys-auth/polkit-kde-agent/ChangeLog
+++ b/sys-auth/polkit-kde-agent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-auth/polkit-kde-agent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-kde-agent/ChangeLog,v 1.20 2015/03/13 14:55:38 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-kde-agent/ChangeLog,v 1.21 2015/03/22 13:38:38 johu Exp $
+
+*polkit-kde-agent-0.99.1-r1 (22 Mar 2015)
+
+ 22 Mar 2015; Johannes Huber <johu@gentoo.org>
+ +polkit-kde-agent-0.99.1-r1.ebuild:
+ Fix src_prepare to respect LINGUAS, bug #543086.
13 Mar 2015; Michael Palimaka <kensington@gentoo.org>
polkit-kde-agent-0.99.1.ebuild:
diff --git a/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild b/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild
new file mode 100644
index 000000000000..105c4f47f3eb
--- /dev/null
+++ b/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-auth/polkit-kde-agent/polkit-kde-agent-0.99.1-r1.ebuild,v 1.1 2015/03/22 13:38:38 johu Exp $
+
+EAPI=5
+
+MY_PN="${PN}-1"
+MY_P="${MY_PN}-${PV}"
+EGIT_REPONAME="${MY_PN}"
+KDE_LINGUAS="ar bs ca ca@valencia cs da de el en_GB eo es et fi fr
+ ga gl hr hu is it ja kk km lt mai mr ms nb nds nl pa pl pt pt_BR
+ ro ru sk sl sr sr@ijekavian sr@ijekavianlatin sr@latin sv th tr
+ ug uk vi zh_CN zh_TW"
+inherit kde4-base
+
+DESCRIPTION="PolKit agent module for KDE"
+HOMEPAGE="http://www.kde.org"
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ SRC_URI="https://launchpad.net/ubuntu/+archive/primary/+files/${MY_PN/-agent/}_${PV}.orig.tar.xz"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+SLOT="4"
+IUSE="debug minimal"
+
+RDEPEND="
+ >=sys-auth/polkit-qt-0.103.0
+ !sys-auth/polkit-kde
+"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+"
+
+if [[ ${KDE_BUILD_TYPE} != live ]] ; then
+ S=${WORKDIR}/${MY_P}
+fi
+
+src_prepare() {
+ kde4-base_src_prepare
+
+ # Coinstallability with kde-plasma/polkit-kde-agent
+ use minimal && rm -rf po
+}