summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-10-24 17:42:05 +0000
committerFabian Groffen <grobian@gentoo.org>2010-10-24 17:42:05 +0000
commit7f5bfdca4a09562900bd0e1f5e89583179399e8f (patch)
treec735dbac4e9400ccffa9acfa5ef8f5797ee5ce99
parentAdd ~sparc wrt #338548 (diff)
downloadgentoo-2-7f5bfdca4a09562900bd0e1f5e89583179399e8f.tar.gz
gentoo-2-7f5bfdca4a09562900bd0e1f5e89583179399e8f.tar.bz2
gentoo-2-7f5bfdca4a09562900bd0e1f5e89583179399e8f.zip
Update reference fixing for Darwin for newer more strict versions of Portage
(Portage version: 2.2.01.17063-prefix/cvs/Darwin powerpc)
-rw-r--r--sys-devel/clang/ChangeLog7
-rw-r--r--sys-devel/clang/clang-2.8-r2.ebuild14
-rw-r--r--sys-devel/clang/clang-9999.ebuild18
3 files changed, 31 insertions, 8 deletions
diff --git a/sys-devel/clang/ChangeLog b/sys-devel/clang/ChangeLog
index e0b56f26d380..df4c96d58c04 100644
--- a/sys-devel/clang/ChangeLog
+++ b/sys-devel/clang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/clang
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.30 2010/10/24 12:11:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/ChangeLog,v 1.31 2010/10/24 17:42:05 grobian Exp $
+
+ 24 Oct 2010; Fabian Groffen <grobian@gentoo.org> clang-2.8-r2.ebuild,
+ clang-9999.ebuild:
+ Update reference fixing for Darwin for newer more strict versions of
+ Portage
24 Oct 2010; Fabian Groffen <grobian@gentoo.org> clang-2.8-r2.ebuild,
+files/clang-2.8-darwin-prefix.patch:
diff --git a/sys-devel/clang/clang-2.8-r2.ebuild b/sys-devel/clang/clang-2.8-r2.ebuild
index a99a9f7ee4aa..f21b7dbe3656 100644
--- a/sys-devel/clang/clang-2.8-r2.ebuild
+++ b/sys-devel/clang/clang-2.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8-r2.ebuild,v 1.2 2010/10/24 12:11:06 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-2.8-r2.ebuild,v 1.3 2010/10/24 17:42:05 grobian Exp $
EAPI=3
@@ -157,18 +157,22 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in lib{CIndex,clang}.dylib ; do
+ for lib in libclang.dylib ; do
ebegin "fixing install_name of $lib"
install_name_tool -id "${EPREFIX}"/usr/lib/llvm/${lib} \
"${ED}"/usr/lib/llvm/${lib}
eend $?
done
- for f in c-index-test ; do
- ebegin "fixing reference to libclang.dylib in $f"
+ for f in usr/bin/{c-index-test,clang} usr/lib/llvm/libclang.dylib ; do
+ ebegin "fixing references in ${f##*/}"
install_name_tool \
-change "@rpath/libclang.dylib" \
"${EPREFIX}"/usr/lib/llvm/libclang.dylib \
- "${ED}"/usr/bin/$f
+ -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ "${EPREFIX}"/usr/lib/llvm/libLLVM-${PV}.dylib \
+ -change "${S}"/Release/lib/libclang.dylib \
+ "${EPREFIX}"/usr/lib/llvm/libclang.dylib \
+ "${ED}"/$f
eend $?
done
fi
diff --git a/sys-devel/clang/clang-9999.ebuild b/sys-devel/clang/clang-9999.ebuild
index 613fed40a296..3e19885d77e5 100644
--- a/sys-devel/clang/clang-9999.ebuild
+++ b/sys-devel/clang/clang-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.10 2010/10/06 09:22:22 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/clang/clang-9999.ebuild,v 1.11 2010/10/24 17:42:05 grobian Exp $
EAPI=3
@@ -143,9 +143,23 @@ src_install() {
# Fix install_names on Darwin. The build system is too complicated
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
- for lib in libCIndex.dylib ; do
+ for lib in libclang.dylib ; do
+ ebegin "fixing install_name of $lib"
install_name_tool -id "${EPREFIX}"/usr/lib/llvm/${lib} \
"${ED}"/usr/lib/llvm/${lib}
+ eend $?
+ done
+ for f in usr/bin/{c-index-test,clang} usr/lib/llvm/libclang.dylib ; do
+ ebegin "fixing references in ${f##*/}"
+ install_name_tool \
+ -change "@rpath/libclang.dylib" \
+ "${EPREFIX}"/usr/lib/llvm/libclang.dylib \
+ -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ "${EPREFIX}"/usr/lib/llvm/libLLVM-${PV}.dylib \
+ -change "${S}"/Release/lib/libclang.dylib \
+ "${EPREFIX}"/usr/lib/llvm/libclang.dylib \
+ "${ED}"/$f
+ eend $?
done
fi
}