summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-01-01 16:58:20 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-01-01 16:58:20 +0000
commit7f0ba2ee21fb9c3bd44f6acfa41d1312027626a3 (patch)
treebc49d55c7eb637d290ecd8e8044196116d4ba2e1
parentUpdate init.d script to use mysql, add myself as a maintainer (diff)
downloadgentoo-2-7f0ba2ee21fb9c3bd44f6acfa41d1312027626a3.tar.gz
gentoo-2-7f0ba2ee21fb9c3bd44f6acfa41d1312027626a3.tar.bz2
gentoo-2-7f0ba2ee21fb9c3bd44f6acfa41d1312027626a3.zip
Version bump.
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.7 i686)
-rw-r--r--net-p2p/transmission/ChangeLog9
-rw-r--r--net-p2p/transmission/transmission-1.42.ebuild52
2 files changed, 59 insertions, 2 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index 3693e33dafae..35789ddd7bf0 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/transmission
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.68 2008/11/17 21:52:05 flameeyes Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.69 2009/01/01 16:58:20 ssuominen Exp $
+
+*transmission-1.42 (01 Jan 2009)
+
+ 01 Jan 2009; <ssuominen@gentoo.org> +transmission-1.42.ebuild:
+ Version bump.
17 Nov 2008; Diego E. Pettenò <flameeyes@gentoo.org>
files/transmission-1.11-libnotify-option.patch:
diff --git a/net-p2p/transmission/transmission-1.42.ebuild b/net-p2p/transmission/transmission-1.42.ebuild
new file mode 100644
index 000000000000..d61db7336862
--- /dev/null
+++ b/net-p2p/transmission/transmission-1.42.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-1.42.ebuild,v 1.1 2009/01/01 16:58:20 ssuominen Exp $
+
+EAPI=2
+
+inherit fdo-mime
+
+DESCRIPTION="A Fast, Easy and Free BitTorrent client"
+HOMEPAGE="http://www.transmissionbt.com"
+SRC_URI="http://download.${PN}bt.com/${PN}/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk nls libnotify"
+
+RDEPEND=">=dev-libs/glib-2.16
+ || ( >=net-misc/curl-7.16.3[ssl] >=net-misc/curl-7.16.3[gnutls] )
+ >=dev-libs/openssl-0.9.4
+ gtk? ( >=x11-libs/gtk+-2.6
+ >=dev-libs/dbus-glib-0.70
+ libnotify? ( >=x11-libs/libnotify-0.4.4 ) )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ dev-util/intltool )
+ dev-util/pkgconfig"
+
+src_configure() {
+ local myconf="--disable-dependency-tracking --with-wx-config=no"
+
+ econf \
+ $(use_enable gtk) \
+ $(use_enable libnotify) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS NEWS
+
+ doinitd "${FILESDIR}"/transmission-daemon
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}