summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-01-04 02:28:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-01-04 02:28:43 +0000
commit60d4efb0a83e56479be74b296f849d3371f64c43 (patch)
tree978a6bd93d3bce6c367a21116afb7e91182514fe
parentEAPI=5 (diff)
downloadgentoo-2-60d4efb0a83e56479be74b296f849d3371f64c43.tar.gz
gentoo-2-60d4efb0a83e56479be74b296f849d3371f64c43.tar.bz2
gentoo-2-60d4efb0a83e56479be74b296f849d3371f64c43.zip
EAPI=5
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--games-mud/mudix/ChangeLog8
-rw-r--r--games-mud/mudix/mudix-4.3-r1.ebuild17
2 files changed, 15 insertions, 10 deletions
diff --git a/games-mud/mudix/ChangeLog b/games-mud/mudix/ChangeLog
index 825151eb02d3..d3875ca4cdc2 100644
--- a/games-mud/mudix/ChangeLog
+++ b/games-mud/mudix/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-mud/mudix
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mudix/ChangeLog,v 1.16 2011/01/12 22:55:17 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mudix/ChangeLog,v 1.17 2015/01/04 02:28:43 mr_bones_ Exp $
+
+ 04 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> mudix-4.3-r1.ebuild:
+ EAPI=5
12 Jan 2011; Michael Sterrett <mr_bones_@gentoo.org> mudix-4.3-r1.ebuild:
add prepgamesdirs; tidy
@@ -56,4 +59,3 @@
27 Feb 2002; Bruce A. Locke <blocke@shivan.org> mudix-4.0.ebuild :
Mudix ebuild contributed by robin@crondor.net (Robin Bakels)
-
diff --git a/games-mud/mudix/mudix-4.3-r1.ebuild b/games-mud/mudix/mudix-4.3-r1.ebuild
index 4e9c22bceac5..fb51ad0c4360 100644
--- a/games-mud/mudix/mudix-4.3-r1.ebuild
+++ b/games-mud/mudix/mudix-4.3-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/mudix/mudix-4.3-r1.ebuild,v 1.6 2011/01/12 22:55:17 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/mudix/mudix-4.3-r1.ebuild,v 1.7 2015/01/04 02:28:43 mr_bones_ Exp $
-EAPI=2
+EAPI=5
inherit eutils games
DESCRIPTION="A small, stable MUD client for the console"
@@ -14,16 +14,19 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND=""
+DEPEND="sys-libs/ncurses"
+RDEPEND=${DEPEND}
-PATCHES=( "${FILESDIR}"/${P}-as-needed.patch )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+}
src_compile() {
- emake -C src O_FLAGS="${CFLAGS}" || die
+ emake -C src O_FLAGS="${CFLAGS}"
}
src_install () {
- dogamesbin mudix || die
+ dogamesbin mudix
dodoc README sample.usr
prepgamesdirs
}